`
bcyy
  • 浏览: 1823614 次
文章分类
社区版块
存档分类
最新评论

杭电OJ——1157 Who's in the Middle(水题)

 
阅读更多

Who's in the Middle


Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input
* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output
* Line 1: A single integer that is the median milk output.

Sample Input
5 2 4 1 3 5

Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.

Source

Recommend
mcqsmall
只要排一下序就可以了!
#include<iostream>
#include<algorithm>
using namespace std;

bool cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int num,i;
	int arr[10050];
	while(scanf("%d",&num)!=EOF)
	{
		for(i=0;i<num;i++)
			cin>>arr[i];
		sort(arr,arr+num,cmp);
		cout<<arr[(num-1)/2]<<endl;
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics