`
bcyy
  • 浏览: 1823423 次
文章分类
社区版块
存档分类
最新评论

杭电OJ——1035 Robot Motion

 
阅读更多

Robot Motion



Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input
3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0

Sample Output
10 step(s) to exit 3 step(s) before a loop of 8 step(s)

题目不难,可是容易出错!千万细心!

现在贴代码!

#include<iostream>
#include<string>
#include<cstdio>
using namespace std;
const int SIZE=100;

int step[4][2]={0,-1,  1,0,  0,1, -1,0};

int main()
{
	string str[SIZE];
	char flag;
	int row,line,place;
	int loop;
	int i,m,n,k;
	int p,q;
	while(scanf("%d%d%d",&row,&line,&place))//行列
	{
		if(row==0 && line==0 && place==0) break;
		for(i=0;i<row;i++)
		{
			cin>>str[i];
		}
		flag=str[0][place-1];
		

		m=0;  n=place-1;  k=0;
		

		loop=0;
		while(0<=m && m<row && 0<=n && n<line)
		{	
			
			
			p=m;q=n;
			flag=str[m][n];//取得该处的值

			if(flag!='E' && flag!='W' && flag!='S' && flag!='N')
			{
				loop=1;
				break;
			}//不为这四点说明循环!就退出!

            
			str[m][n]=1+k;
            
			k++;
		
			switch(flag)
			{
				case 'N':m=m+step[0][1];n=n+step[0][0]; break;
				case 'E':m=m+step[1][1];n=n+step[1][0]; break;
				case 'S':m=m+step[2][1];n=n+step[2][0]; break;
				case 'W':m=m+step[3][1];n=n+step[3][0]; break;
			}
			
			
		}
		if(loop)
		printf("%d step(s) before a loop of %d step(s)\n",str[m][n]-1,k+1-str[p][q]);
		else
		printf("%d step(s) to exit\n",str[p][q]);
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics