`
bcyy
  • 浏览: 1823580 次
文章分类
社区版块
存档分类
最新评论

杭电OJ--1027 Ignatius and the Princess II

 
阅读更多

Ignatius and the Princess II


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input
6 4 11 8

Sample Output
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

题目倒是不太难!这是多亏了next_premutation函数的莫大神奇!

关于next_permutation函数,参阅http://blog.csdn.net/lishuhuakai/article/details/8006937

废话不多说,参考代码!

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int SIZE=1002;

int main()
{
	int n,m;
	int i,count;
	int seq[SIZE];
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		for(i=0;i<SIZE;i++)
		seq[i]=i+1;
		 count=0;
		do
		{
			count++;
			if(count==m)
			{
				for(i=0;i<n;i++)
				if(i==n-1)
				cout<<seq[i];
				else
				cout<<seq[i]<<" ";
				cout<<endl;
				break;
			}
		}
		while (next_permutation(seq,seq+n));
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics