`
bcyy
  • 浏览: 1823450 次
文章分类
社区版块
存档分类
最新评论

SPOJ - 42. Adding Reversed Numbers 整数反正问题

 
阅读更多

给出两个已经反转了的整数,如何求得原数相加之后的反转的数呢?

其中有去零的要求,可以看题:

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play.

Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.

ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).

Input

The input consists ofNcases (equal to about 10000). The first line of the input contains only positive integerN. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.

Output

For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.

Example

Sample input: 

3
24 1
4358 754
305 794

Sample output:

34
1998
1

会反正整数的基础就好办了, 那么本题就是多次反正整数了,注意要使用longlong,因为反转整数的时候也有可能溢出的。

看看如何反正整数吧:

#pragma once
#include <iostream>
#include <vector>
#include <string>
using namespace std;

long long revs(long long a)
{
	long long b = 0;
	while (a)
	{
		b = b * 10 + a % 10;
		a /= 10;
	}
	return b;
}
void AddingReversedNumbers()
{
	long long a = 0, b = 0;
	int T = 0;
	cin>>T;
	while (T--)
	{
		cin>>a>>b;
		a = revs(a) + revs(b);
		cout<<revs(a)<<endl;
	}
}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics